Sage Fixed Assets 2018.1 Crystal Reports Compatibility Issue

 
 
Sage Fixed Assets 2018.1 was updated to Crystal Reports runtime SP21 which may cause an issue with Crystal Reports runtime versions used for other products. If you upgraded to Sage Fixed Assets 2018.1, you may experience a compatibility issue if you are also using Sage 100 (2017 and earlier), Sage 300 (2017 and earlier), Sage 300 CRE (v15.1, v16.1, and v17.1), or Sage 500 (2017 and earlier).
Resolution
Click your product below to open the Knowledgebase article that includes the steps to resolve the issue:
Questions?
We're here to help! Contact your Sage business partner, visit Sage City to join product discussions, search articles in the Sage Knowledgebase, or chat with an expert.
 
And for year-end tips, updates, and information, visit the Sage Year-end Center at www.SageCity.com/YearEnd—bookmark it today!
Anonymous
  • So I've been having some issues with this on a Sage 100 2016 Standard system. Here's what happened:
    1. One user is running both Sage 100 and Fixed Assets client. Other users just run Sage 100.
    2. User was prompted to upgrade SFA Client to 2018.1, which then "broke" reporting in Sage 100 (a la KB 89164)
    3. I copied the pvxwin32.exe.config file to the server and reinstalled the SFA Client.
    4. That worked in as much as that one user can now print in both SFA and Sage 100.
    5. However, now all 8 Sage 100 users that don't run the SFA Client are now getting the "Module R/A is not on file.:Crystal" error, per KB 52776. or KB 88721, if you prefer.
    6. I have just reconnected into a workstation that is running Sage 100 only, reran the workstation setup, removed the pvxwin32.exe.config file from the Home folder on the server and now all the Sage 100 only workstations are fine.
    7. But now the workstation running Sage Fixed Assets gets the "..cast COM.." error trying to print or preview in Sage 100. The good news is he can print and preview in Fixed Assets.
    So per Resolution #2 I suppose the answer is to put the .config file back and either install the fixed assets client on each Sage 100 workstation or put on the Crystal patch. The problem with that is that it is a lot of work and the customer doesn't want to jump through all those hoops.
    Any thoughts?

  • Has anything been done to correct this issue for Sage X3 v6?

  • Hi,

    See the link to Kb 89164  It was updated Friday Feb 9 for Sage 100 and SFA 2018.1.

     John Nichols Sage

  • Hello, with regards to the Sage 300 (2017 and earlier) link, it leads to a page for the Sage 300 2018 patch. Does this also apply to Sage 300 2017 and prior or will another update be released? Thanks!