Strange Problem With Multi-User Mode

Hi,

I am trying to troubleshoot an issue with multi-user mode. Unfortunately, attempts to open two concurrent user sessions on a single company fail with the following error message:

"Simply Accounting cannot open the database because some of the database files are read-only. Please ensure you have sufficient rights to the files, then try again."

I have tested that both workstations can access the company if there is only one connection to it. This suggests to me that the problem is not related to incorrect file permissions. I also checked the support information and determined that the "Shared company" property was set to TRUE. I assume this means that multi-user mode is allowed.

Hoping to resolve the issue, I followed the steps described in the "Setting up Multi-User mode" article from the Sage knowledgebase. After creating a new company from the existing one I could establish two simultaneous connections. I tried closing and re-opening the company on the remote computer (not hosting the file shares) and I still had no problems. However, closing and re-opening the company on the computer hosting the files made it impossible to establish 2 simultaneous connections after that.

Please help me find a solution to this problem.

Thanks,

Collin

 

 

  • clavoie

    Hi,

    I am trying to troubleshoot an issue with multi-user mode. Unfortunately, attempts to open two concurrent user sessions on a single company fail with the following error message:

    "Simply Accounting cannot open the database because some of the database files are read-only. Please ensure you have sufficient rights to the files, then try again."

    I have tested that both workstations can access the company if there is only one connection to it. This suggests to me that the problem is not related to incorrect file permissions. I also checked the support information and determined that the "Shared company" property was set to TRUE. I assume this means that multi-user mode is allowed.

    Hoping to resolve the issue, I followed the steps described in the "Setting up Multi-User mode" article from the Sage knowledgebase. After creating a new company from the existing one I could establish two simultaneous connections. I tried closing and re-opening the company on the remote computer (not hosting the file shares) and I still had no problems. However, closing and re-opening the company on the computer hosting the files made it impossible to establish 2 simultaneous connections after that.

    Please help me find a solution to this problem.

    Thanks,

    Collin

     

     

     

    I think the "some database files...." is a generic 'access denied' message that the Simply Connector sends when it cannot open the files for read / write.

    How many user connections are allowed on the Windows share from the server machine?  I don't think this shoulld matter, the .SAI file is just a descriptor of the database in the .SAJ directory.

    If the file is opened from one workstation, can you open it locally with a different user ID? 

    I'm not sure if this is a Windows, network issue or a Simply issue. 

    Hope that helps,

    Randy

  • Hi everyone,

    I just wanted to share the solution to this problem.

    Basically, the issue arose from the fact that Simply Accounting was started from a shortcut to the company .sai file (ex: \\ipaddress\simplydata\mycompany\mycompany.sai).

    If Simply Accoulting is opened normally (using the standard shortcut), and the company location is specified using the Select an existing company option, multi-user works properly.

    Collin

More Content