Timeslips totally locks up



I ran into a problem where I decommissioned a PC with Timeslips, and then reinstalled it on another PC. After I restored the database and ran the service update (version 2008) Timeslips totally locked up. the pull down menus worked, but nothing would happen when selecting an option. Timeslips would not even close without having to go to task manager and terminating the program that way.


I called Sage tech support. Apparently Sage put some sort of whammy in the program the prevents it from operating if TeamViewer is running on the PC. Once Teamvewer is shutdown, Timeslips operates just fine.


This is Sage's way of forcing people to purchase their TSRemote license.


It totally handicaps the IT Technicians to be able work on the PCs remotely.


Thumbs down to this. Not happy.

  • Not quite sure how you take an incompatibility with a remote access product that I have never heard of before to mean this is Sage's way of forcing you to purchase a TSRemote license?


    TSRemote was (no longer sold) a version of Timeslips for travellers or those not on a network to use to track time and expenses.  The slip transactions still need to be transferred to the main Timeslips system for billing. 

  • This is a very helpful site.  Has anyone found a solution to Timeslips freezing when Teamviewer is running?  Thank you Aloha Paul

  • I agree with Allen, I don't think it is fair to blame Sage. It actually worked fine with Teamviewer until recently. I think there was an update by Teamviewer or Microsoft that led to a compatiblity issue.

More Content