Simply Accounting has stopped working

Sage 50 Accounting - Canadian Edition

Sage 50 Accounting - Canadian Edition
Solutions are just a click away as you share, learn and network with other small business owners, bookkeepers, and accountants. Sage 50 Accounting support specialists and knowledgeable fellow users are ready to help!

Simply Accounting has stopped working

  • Hi,

     

    I've installed Simply Accounting First Step 2010 on my windows 7 computer. Whenever I click to start the program, the following message comes up: Simply Accounting has stopped working. Windows will notify you if a solution is available.

    I've tried all the different things people have done to fix this program including:

    1) changing the "hosts" file to include the extra verbage about localhost

    2) installing the program under a different folder (it installs by default under the c:/Program Files (x86) folder but I've tried it under just the c: drive, or even under the c:/Program Files folder, and still the same message comes up)

    3) setting up a new user acccount on my computer and installing it within that new user account

    Nothing works.? I do not have any previous versions of Simply Accounting.

    I can, however, open all the different programs/files under the start menu including: company file check & repair, new business guide, help, connection manager, troubleshooter. It's just when I click on the actual Simply Accounting program the error message comes up. The error message does not contain any error reference #.

  • Hi mzebby,

    I'm sorry you're receiving the 'Stopped working' error message after installing Sage Simply Accounting First Step.  If you have already made the adjustment to your hosts file and are still encountering the 'Stopped working' error, can you go to:

    c:\users\public\documents\simply accounting\2011\samdata\first step

    Open the universl.SAI file there and see if it opens.  If that opens try to create a new company file and save it to your desktop.  Let know if you encounter any errors and at what point you encounter the error message.

    Thank you

  • Hi,

    As soon as I click on the universal.sai file, the same error message comes up: Simply Accounting by Sage 2010 has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

    Thanks,
    MZ

  •  Hi,

    It sounds like something went wrong, or didn't finish, during the installation.

    I would suggest:

    1.  Uninstall Simply Accounting

    2.  Run Disk Cleanup as in this article http://support.microsoft.com/kb/3103123.  The purpose of this is to delete any temp files. 

    3.  Try the installation again.

    I hope that helps, please post back.

    Randy

  • Hi,

    I've unstalled Simply Accounting, performed a disk clean up, restarted my computer, re-installed Simply Accounting and the same error still comes up.

    I have a question: Simply Accounting gets installed into this location by default: C:\Program Files (x86)\Simply Accounting First Step 2010

    however, I do not see a hosts file under this location: C:\Windows\SysWOW64\drivers, actually, I don't even see the "etc" folder where the "hosts" file would be located.

    There is a hosts file in this location: C:\Windows\System32\drivers\etc.

    Since Simply Accounting is installed in my Program Files (x86), would I not also need a hosts file under the SysWOW64 folder?

    MZ

  •  Hi,

    There is only one HOSTS file for a physical device.  So, no you don't need another one.

    To test:  Run 'CMD', type PING LOCALHOST.

    You should see a response "pinging mycomputername [127.0.0.1]"

    If that's working, the cause of the problem lies elsewhere.

    Randy

  • Hi, here is what I get when I perform the ping:

    -----------------------------------------------------------------------------------------------

    Pinging mypcname-PC [: : 1] with 32 bytes of data:

    Reply from : : 1 : time<1ms

    Reply from : : 1 : time<1ms

    Reply from : : 1 : time<1ms

    Reply from : : 1 : time<1ms

    Ping statistics for : : 1 :

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 0ms, Average = 0ms

    ---------------------------------------------------------------------------

    Sounds like I have to update the hosts file again?

  •  Hi,

    Yes.

    It appears that there is another localhost entry further down in the file.,  You can comment it out by putting a # in front of it.  (It's been over a quarter century since Typing 10, I think it's an octothorpe?)  Or, put your entry in further down.

    It's the last entry that 'sticks' as the lookup value.

    Oh, another possiblity occured to me.  Notepad helpfully sticks a .TXT on the end of every file you save without an extension.  Windows will ignore any hosts file that has an extension.  To make sure it's saved as 'hosts' and not 'hosts.txt', upon saving the file you have to change it from type 'text file' to 'all files'.  This little feature is made worse by the otherwise convenient default in Windows to 'hide extensions for known file types' 

    I don't know if the antique DOS program 'Edit' is still included with Windows 7, it is much less automatic, which makes it a better choice for this sort of work.

    I hope that helps, please post back!

    Randy

  • Hi,

    I'm using this microsoft help website to restore my hosts file:

    http://support.microsoft.com/kb/972034

    I've changed my original hosts file to be hosts.bak. Now I'm on the step where you have to right click>new>text document but I do not have this option available. All I have availabel is right click>new>folder. There is no option for text document.

    Help?

    MZ

  • Make sure that you are right clicking on the right hand pane in Windows Explorer! 

    I don't know why you are doing this, the information from your ping, looks good to me!

    it shows 0% loss , 4 sent and 4 received; which means that the ping of localhost was good!

  • Yes, the ping of localhost was good, but Simply Accounting is crashing because it can't resolve the loopback address to the name of the local computer, or vice versa.

    It's the inability to resolve the loopback address as a valid IP address that seems to be the problem, for which changing the HOSTS file is intended to be the solution, for Simply Accounting and Windows 7.  ::1: is a valid loopback address for IPV6, but doesn't seem to be comprehensible to Simply Accounting.  

    "Reply from : : 1 : time<1ms"  This is shorthand for the 0:0:0:0:0:0:0:1 loopback address for IPV6.  Note the date on this post:

    http://www.realgeek.com/forums/reply-from-1-time-1ms-463848.html

    This is not an error, deficiency, bug, or problem that just appeared in Windows 7.  IPV6 awareness should probably be added to Simply Accounting, if it is possible to do so.   Having the program just crash on a computer with IPV6 (it's 7 year old technology!), and providing only a workaround of digging into the guts of TCP/IP networking to get it to start up, is pretty poor!

    Defining localhost for loopback, from http://en.wikipedia.org/wiki/Localhost

    "...In IPv6, on the other hand, the loopback routing prefix ::1/128 consists of only one address ::1 (0:0:0:0:0:0:0:1 in full notation), the address with a one at its least significant bit and zero otherwise) is explicitly defined as the loopback address,[6] though additional addresses may be assigned as needed to the loopback interface by the host administrator...

    "

  • Yes, the ping of localhost was good, but Simply Accounting is crashing because it can't resolve the loopback address to the name of the local computer, or vice versa.

    It's the inability to resolve the loopback address as a valid IP address that seems to be the problem, for which changing the HOSTS file is intended to be the solution, for Simply Accounting and Windows 7.  ::1: is a valid loopback address for IPV6, but doesn't seem to be comprehensible to Simply Accounting.  

    "Reply from : : 1 : time<1ms"  This is shorthand for the 0:0:0:0:0:0:0:1 loopback address for IPV6.  Note the date on this post:

    http://www.realgeek.com/forums/reply-from-1-time-1ms-463848.html

    This is not an error, deficiency, bug, or problem that just appeared in Windows 7.  IPV6 awareness should probably be added to Simply Accounting, if it is possible to do so.   Having the program just crash on a computer with IPV6 (it's 7 year old technology!), and providing only a workaround of digging into the guts of TCP/IP networking to get it to start up, is pretty poor!

    Defining localhost for loopback, from http://en.wikipedia.org/wiki/Localhost

    "...In IPv6, on the other hand, the loopback routing prefix ::1/128 consists of only one address ::1 (0:0:0:0:0:0:0:1 in full notation), the address with a one at its least significant bit and zero otherwise) is explicitly defined as the loopback address,[6] though additional addresses may be assigned as needed to the loopback interface by the host administrator...

    "

  • Hi,

    I was able to get my hosts file back. I have once again used this website (http://support.microsoft.com/kb/972034) to input the appropriate wording in the hosts file and Simply Accounting stills says it has stopped working. I've tried XP, Vista and Windows 7 wording. I've even tried Windows 7 and removed the last two # signs like so, and it still doesn't work:

    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host

    # localhost name resolution is handle within DNS itself.
    127.0.0.1 localhost
    ::1 localhost
  •  Hi,

    You almost have it, all you need to do is comment out (put a # in front of) the last line.

    Windows reads the commands in order, so your setting for 127.0.0.1 for Localhost was being overwritten by the last line.

    Hope that helps!

     

    Randy

     

  • Argh, still saying "This program has stopped working." What am I doing wrong here:

    # Copyright (c) 1993-2006 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host
    #
    # localhost name resolution is handle within DNS itself.
           127.0.0.1       localhost
    #      ::1             localhost