A required data file is missing

Sage 50 Accounting - Canadian Edition

Sage 50 Accounting - Canadian Edition
Solutions are just a click away as you share, learn and network with other small business owners, bookkeepers, and accountants. Sage 50 Accounting support specialists and knowledgeable fellow users are ready to help!

A required data file is missing

  • I never had a problem backing up the accounting files and restoring them. Something has changed. Ever since I downloaded and installed the latest update "SA_20132CPUP1" all of my users including my accounting firm have problems restoring the backup "Test _ Company.CAB" file.  The following error message appears.

    "Cannot open company file ........... A required data file is missing. Check your data directory to be sure the files are there."

    I checked, the files are there, I have also followed the online instructions from SAGE but to no avail, I am unable to restore the file my accountant sent me. I uninstalled & reinstalled SAGA to start with a clean slate but the problem persists.  And yes all users incl. the accountant are using the same SAGE 50 version.  SAGE needs to realize and admit that there is a problem and post a fix that users can download.  In today's computer environment it should not be this difficult to backup / restore a file.  Can anyone help with simple instructions please ... as I am not a computer guru?

  • FYI

    I don't think that it is a problem with the patch as I am running the same version and I do not have this issue, I am able to backup and restore recent backups with no problems; running Windows 7 x64 with the data-file on a windows 2008 R2 file server.

    Have you tried the backup and restore using the sample database files, just to confirm that the backup & restore operations are working properly?

    When you do a backup, do you do a verify of the data?

  • I am running Windows 7 x64 as well.

    You may have a point. I can backup and restore files from my other two companies with no problem.

    As to the "Verify backup ....."  I just turned it off today to see if that makes a difference (I read in another blog that I should turne off that feature)

    My Accountant will email me the new CAB file in the morning. This back up will be done with the VERIFY feature turned off ... will see.

    Could it be possible that the files get damaged during emailing?  I don't know, I am at the end of my knowledge.

    Hopefully someone comes up with a easy fix.

  • If the file was sent by e-mail, just in the raw cab format; it is possible that it may have been damaged by the AV software scanning the file.  Perhaps your accountant could zip the cab file prior to e-mailing it and put a password on the file, this may prevent the files from being scanned by the AV software at either end.

    Another possibility would be to place the file on a secure file share site and have you retrieve it from the web site.

    I always verify my backups and it has never been an issue, I am going to look at any forum postings on this subject, I scan most posting to this forum and do not recall it being a topic of concern!

     

  • Can I jump into this thread?  I'm experiencing the same issue - required file missing - where & how do I check???  I have SA 2009, 2011 & 2012 on my computer and have had to install (temporarily) Sage 50 only to be able to view a file supplied by an accting firm i'm helping out for 1 client.  She's not familiar with Simply and has accidentally converted this clients data to the Sage 50 format.  I think that the program was the problem as when i loaded it it seems to have converted ALL of my accting files to the Sage 50 format!!  I've had to do a system restore to get them back to some functionality but some (the 2009 files) are giving me an error that i have a missing data file.... help!

     

  • Hi Vicky,

    You may find the article below helpful to your issue.

     260-24351 - Error "A required data file is missing" when opening a data file.