Peachtree 2011 Emailing not working anymore

Sage 50 Accounting U.S.

Sage 50 Accounting U.S.
Welcome to the Sage 50 Accounting U.S. edition product support community! Here you can ask questions, discuss the product and share best practices with other Sage 50 U.S. users.

Peachtree 2011 Emailing not working anymore

  • We've used the emailing capability within Peachtree 2011 (to Outlook 2010) for over 6 months.  Recently, I had to reinstall Peachtree 2011 and unfortunately, after the reinstall, emailing no longer works.  When I attempt to email from Peachtree, nothing happens...no error messages, nothing.

     

    All other programs on my Windows 7 machine recognize Outlook as the default mail program and can initiate emails through it.

     

    Anyone know how to figure out why Peachtree can't seem to trigger Outlook to send an email?  The default mail program is properly set to Outlook 2010.  I've tried changing it over to Windows Live Mail, but Peachtree can't seem to trigger that program either.  Sounds like an issue on the Peachtree side, but I can't figure out what to check.

     

    Thanks,

    Chris

  • Try temporarily disabling your firewall.  If it works with your firewall turned off, then you need to set exceptions in your firewall to allow Peachtree to work.  You can find details on setting up your firewall to work with Peachtree here.

     

    If you aren't sure which firewall you are using, download Sage's Security Application Scanner.   It would also be a good idea to try this if turning off your firewall didn't fix the problem.  You may have more than one program running that is blocking Peachtree.

  • Steven,

     

    Thank you for your reply.

     

    Unfortunately, the firewall isn't the issue in this case.  I sit behind my Linksys router which acts as my firewall so I don't run a firewall locally on my machine.  Also, I use Microsoft Security Essentials as my antivirus protection.  Even with that off, there is no change.

     

    One other odd piece of data:

    If I am at a Peachtree screen that has a "Send to" button (like the Sales Invoice List), I can use "Send To Email" and it works great...the email is generated perfectly.  However, if I click into one of these invoices and I'm only presented with the Email button (vs. the Send to), the email button gives no response.  In addition, when I "print" an invoice for a customer that is set up as for "E-mail" as their batch delivery method, no email is generated (this used to work just fine).

     

    I can't imagine how the "Send to Email" button differs from the plain "Email" button behind the scenes, but this distinction definitely seems to be the deciding factor on whether the function works or not.

     

    Thanks,

    Chris

  • Chris, I feel your pain  :smileywink:

     

    I can't email period.  I tried the send to and the send.  WHen I hit send I get nothing.  WHen I hit the send to in an invoice list I get a message that my MAPI whatever is not set up.  Well, it is set up and is working fine on my laptop...or it was.  IT's not working on this computer and it did for a while. 

     

    Steven and I spend quite a bit of time working on this issue and got to work.  The next day it stopped working.  We thought it was the firewall and we changed the settings.  It's not working now with the firewall on or off.  

     

    Since Outlook is working fine with everything else it's definately not an Outlook problem, it's a Peachtree problem....do you agree Steven  :smileywink:

     

    Nedra

  • No responses to this.  Is Peachtree aware of this problem?  Do they have a representative participating in this Peachtree Community?  

     

    Do any of our certified consultants know if Peachtree is working on a resolution to this problem?

     

    Nedra

  • I have a similar problem on a few of my computers.

     

    Uninstalling and reinstalling the mail client does not seem to help.

  • I am happy to report that I found the issue!

     

    Coincident with my upgrade to Peachtree, I forgot that I had also switched over all of my email accounts to IMAP access instead of the old SMTP method.  It appears that this is what caused the issue.  After many hours of troubleshooting, here was my solution:

     

    1.  In Outlook 2010, under the File - Account Settings - Account Settings dialog box, change to the Data Files tab.

    2.  On this tab, all of my existing data files were .PST files that were created automatically when I added all of my IMAP accounts.  I also had several .OST files that were created when I added some of my Hotmail accounts to Outlook as well.  The key was to use the Add button on this dialog box to create a "dummy" PST workspace for Outlook that was not linked to any of my IMAP or Hotmail (MAPI) email accounts.  I created a new data file called "Temporary Workspace.pst".

    3.  Make sure to use the "Set as Default" button in this dialog to set the new .pst file as the default data file.

    4.  Restart Outlook

    5.  Peachtree now successfully prints just as it used to when I used SMTP to access my email!

     

    During my experimentation, I found that Windows Live Mail was not affected by this quirk.  If I configured all of my email accounts (IMAP and MAPI) in Windows Live Mail and then made it my default email program for "MAPI - Send Mail" under the Windows 7 Default Programs dialog, Peachtree could send to it just fine without having to put any kind of "temporary workspace" file like I had to in Outlook.

     

    It was a long time getting there, but hopefully this will put my issue to rest.

     

    Thank you to everyone that replied to my original post!

     

    Chris

  • Steven, do you think this would resolve the problem I was having?  I am afraid to mess with it right now and since the tech from Microsoft helped me set this up he ensured that the data file was correct and it is working with everything but Peachtree.

     

    Nedra

  • Has anyone found a resolution to this or are we all still having the problem of not being able to email anything from Peachtree?

     

    Nedra